WordPress 5.0 Güncellemesi Yapılmalı mı?


WordPress 5.0 Güncellemesi Yapılmalı mı? 1

“Bebo” Olarak adlandırılan WordPress 5.0 versiyon güncellemesi 7 Aralık 2018 tarihinde piyasaya sürüldü. WordPress 5.0 güncellemesi ile birlikte web sitelerinde bazı problemler yaşatabiliyor. Bu yaşanan sorun genel olarak eklentilerin ve temaların anlık 5.0 güncellemesi alındıktan sonra desteklememesinden kaynaklanıyor. Genel olarak WordPress tarafında yaşanan bu sorun web sitelerinin çalışamaz hale getirmesine neden oldu.  En son 4.9.8 versiyonunda yeni eklenen”GutenBerg” adlı yazı editörü eklenti olarak sunulmuştu. Bu eklentinin kaldırılması ve 5.0 güncellemesi ile birlikte yazı ekleme ve düzenleme sayfasını daha farklı bir hale getirdi. Tasarımsal açıdan yıllarca WordPress kullanımı sağlayan webmaster’lar, bu eklentiye tam olarak alışamadı.

GutenBerg Zorunlu Hale Getirildi!

WordPress son 5.0 güncellemesi ile birlikte getirdiği bu zorunluluk, wordpress kullanıcıları için kötü bir haber niteliği taşıyor. Örnek olarak her gün yazılarını güncel tutan ve klasik yazı editörüne alışan wordpress kullanıcıları, yeni yazı editörünü nasıl devre dışı bırakacaklarını araştırıyor. Bu yazı editörünü devre dışı bırakmak mümkün ancak yazılım tarafında eklenen kısımları kaldırmak gerekli oluyor veya klasik yazı editör eklentisi ile birlikte “GutenBerg” editörünü kaldırmak mümkün. WordPress tarafından geliştirilen bu yazı editörü tasarım açısından şık görünse de, kullanım açısından ihtiyaçları yeterince karşılaşmıyor diyebiliriz.

GutenBerg yazı editörü, klasik yazı editörünün bütün özelliklerini taşıyor ancak tasarım tarafında oldukça farklılık yaşatıyor. Eski klasik yazı editörüne alışan wordpress kullanıcıları, yeni editöre geçiş esnasında zorlanabilirler. WordPress 5.0 güncellemesinden itibaren artık klasik yeni yazı editörü “Gutenberg” olarak görünüyor.

Klasik Yazı Editörü Eklenti Olarak Kullanabilirsiniz

WordPress 5.0 güncellemesini gerçekleştirdikten sonra yeni “Gutenberg” yazı editörünü devre dışı bırakmanız mümkün değil. WordPress 4.9.8 sürümünde yeni yazı editörünü eklenti olarak veren WordPress, bu sefer bir değişiklik gerçekleştirip klasik yazı editörünü eklenti olarak sunuyor ve “Bebo” olarak adlandırdığı WordPress 5.0 versiyonunda yeni gutenberg yazı editörünü standart olarak tutuyor.

Şu anda ilk güncellemesinde bununla birlikte alt yapı değişikliği olması gereklidir ki bazı eklentilerde ve temalarda 5.0 sürümü problem yaratabiliyor. Özellikle özel yazılım olarak kodlanmış WordPress temalarında veya eklentilerinde sorun çıkarabiliyor.

Eklentiler ve Temalar Güncelleme Vermeye Devam Ediyor

WordPress 5.0 güncellemesi ile birlikte bütün eklentiler ve temalar wordpress versiyonu ile uyumlu çalışabilmesi için güncelleme vermeye devam ediyor. Bu güncellemeler ile birlikte “Bebo” olarak adlandırılan WordPress 5.0 güncellemesi güncel tutulan eklentileri ortaya çıkarmayı da başardı.  Temaların güncel tutulması ve WordPress uygulamasının her zaman güncel tutulması çok sağlıklı bir işlemdir tabi, ancak gelen güncellemeler ile birlikte eklentiler ve temalar hazırlıksız yakalandığı için, WordPress kullanıcılarının sitelerinde güncelleme esnasında sorunlar yaşandı. Şu anlık çoğu eklentiye 5.0 desteği getirildi, ancak temalarda şu anda nasıl bir yol izleniyor tam olarak net bir bilgi vermemiz mümkün değil.

Yedeklerinizi Almayı Unutmayın!

WordPress güncellemesinden sonra web sitenizin çalışmama ihtimalini sıfıra indirgemek için güncelleme öncesi bütün yedeklerinizi almanızı öneririz. Her hangi bir olasılığa karşın bu tür durumlarda tedbirinizi alabilirsiniz. Güncelleme sonrası 5.0 versiyonunu desteklemeyen eklentiler veya temalar, web sitenizi bozabilir ve çalışamaz duruma getirebilir. Web sitenizin bozulması durumunda aldığınız eski yedekleri geri yükleyerek web sitenizi çalışır duruma getirebilirsiniz. Turhost.com “Gelişmiş Hosting Yönetim Paneli ile Yedek Alma” adlı makalemizi incelemek için tıklayınız.


Bu Yazıyı Sosyal Medyada Paylaş!

0 Yorum

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir